In order to stop the reverse engineering of script applications, many developers encode their program code with tools such as ionCube PHP Encoder in order to make it human unreadable. The latter is valid for paid applications in particular, as anyone could possibly use and change the unencrypted code without having to pay the necessary license fees. If you purchase web software encrypted with ionCube PHP Encoder, you'll be able to use it without any problems as long as a software instrument named ionCube Loader is a part of the website hosting server. This loader enables you to run encrypted files and you'll often see it on the list of prerequisites for a particular script app to be set up. Since the encoded files are already precompiled, they are ordinarily executed a lot faster and this will boost the general speed of your site.

IonCube in Shared Website Hosting

If you get a Linux shared website hosting through our company, it will be set up on our in-house made cloud hosting platform where ionCube Loader is already set up, so you won't have any problems to run any script application that requires the tool to run properly. We also offer several different versions of PHP, so in case you change the version, you'll need to activate ionCube once again. Our system remembers the adjustments you make, and when you move back to the previous version of PHP that was active for your account, ionCube Loader will already be activated. Both the PHP version and the ionCube instrument can be operated through the PHP Configuration part of our Hepsia website hosting Control Panel. Every adjustment that you make takes literally just a click and it will take effect immediately.

IonCube in Semi-dedicated Hosting

If you buy a semi-dedicated server package from us, you'll be able to employ any script-driven application that requires ionCube Loader as the software tool comes with all servers which are part of our advanced cloud web hosting platform. Furthermore, we support multiple versions of PHP, therefore if you switch from PHP 4 to 5.2 or 5.3, for instance, you can enable ionCube for that particular release with only a click from your Hepsia Control Panel. Our platform will remember your choice, so in case you switch back to the previous release of PHP, the tool will already be active. For more tech-savvy users, we also offer the option to choose the PHP version and whether ionCube will be active or not for a particular domain name without altering the settings for the entire website hosting account. This can be done by placing a php.ini file inside a domain folder with a few lines of program code.